Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: linear drive units/ tiller pilot issues

  1. #11
    Join Date
    Jun 2015
    Posts
    6

    Default

    Had an email back from Brian. He didn't even offer to sell me anything! I emailed him back asking about that.

    Interesting comment about the raymarine drive units. I did not realize they sere so troublesome. The TP uses a belt drive which maybe is better like the 1000 and 2000 but I think the ball screw is heavier in the TP30s than in the RM2000.

    I could always try to get an X5 and drive the TP motor with that, but I think the pelagic setup will be more reasonable.

    Also the end ball joint is getting noticeable worn. Has anyone replaced that with something like a metal tiller extension joint?

  2. #12
    Join Date
    Sep 2007
    Posts
    2,872

    Default

    The General replaced his with a metal piece. The easiest way is to buy RM's 1" Pushrod Extension (P/N D003) and drill a hole in it. Then it's already threaded. Otherwise I have a bag full of the plastic ones but they probably look like yours!

    Brian's wand has a SS tip instead of plastic. "He didn't even offer to sell me anything!" If you're wanting sales hype I can send a copier salesman or insurance guy over.

  3. #13
    Join Date
    Jun 2015
    Posts
    6

    Default deposit

    I talked with him today. I guess he's not making any units till later in the summer. So he's going to put a deposit tab on his shopping cart for those of us wanting one then.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •